ڼС
梦回起点
做你害怕做的事,你会发现:不过如此
本站基于WordPress—主题by 设计窝
冀ICP备15003737号
梦回起点
Copyright © 2015-2018 All rights reserved.

解决Ubuntu/Linux环境下安装StarUML时提示,“依赖关系不满足libgcrypt11>=1.4.5”/”Dependency is not satisfiable: libgcrypt11 (>=1.4.5)”问题

想做个小东西,于是乎下载了StarUML,但是安装的时候确提示:Dependency is not satisfiable: libgcrypt11 (>=1.4.5)(“依赖关系不满足libgcrypt11>=1.4.5”),这个问题我一看,好解决嘛,用apt-get install -f一下不就可以了。试了一下才知道好像找不到这个库。请神奇的百度来帮忙。

于是乎找到了下面链接中的解决方法,但是原贴中的地址已经不能用了,于是乎去掉了文件名用下面的格式在浏览器打开http://mirrors.kernel.org/ubuntu/pool/main/libg/libgcrypt11/

然后找到libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb和这个名字格式相同的包,注意是格式相同,因为版本号一直在更新的。

截止今天可以用下面的代码解决,如果显示404 not found,那么请自行到上面的地址找最新版本

用上面的代码安装完这个包之后再安装StarUML就不会提示依赖关系不满足了。

原贴地址:http://blog.csdn.net/u012325167/article/details/50489629

2016-12-04
解决Ubuntu/Linux环境下安装StarUML时提示,“依赖关系不满足libgcrypt11>=1.4.5”/”Dependency is not satisfiable: libgcrypt11 (>=1.4.5)”问题已关闭评论